10 most Recent Topics - YaBB Development & Mods https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl en-us YaBB Development & Mods Tue, 18 Jan 2022 05:21:25 GMT http://blogs.law.harvard.edu/tech/rss YaBB 2.7.00 Revision: 2044 30 YaBB 2.6.0 and 2.6.1 Support - My forum stopped working with an error https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1635179410/3#3 YaBB Development & Mods/YaBB 2.6.0 and 2.6.1 Support https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1635179410/3#3 no-email@yabbforumsoftware.com (Dandello) Wed, 27 Oct 2021 11:42:09 GMT Use the version found here: <a href="https://sourceforge.net/p/yabb/svn/HEAD/tree/" target="_blank">https://sourceforge.net/p/yabb/svn/HEAD/tree/</a> (Download the snapshot) - make sure you take a backup of your original (You should be able to zip it up and download it.)<br /><br />(And don't trust your ISP to help - they don't know Perl.)<br /><br /> General Board - 2.6.11 Edit Post Bug Resolution https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1619965110/0#0 YaBB Development & Mods/General Board https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1619965110/0#0 Sun, 2 May 2021 14:18:30 GMT <br />Didn't seem to be a clear place for bug reports on old revisions, so I figured I'd just post it here and let you move it if necessary.<br /><br />I updated from 2.5AE to 2.6.11 a while back. In doing so, the ability to edit posts broke - no one, not even mods or admins, can modify a post. While it has made for some amusing incidents, it is a bit of a pain. Well, eventually, one of my members got sick of it, did some debugging, and identified the issue. I'm reporting it here in case it has not been found yet.<br /><br />In cgi-bin/yabb2/Sources/ModifyMessage.pm, around line 766, a closing curly brace was put in the wrong location. This makes it so that if attachments are disabled, edited posts are not saved/posted. Here is the before/after:<br /><br /><span>-- BEFORE --</span><!--color--><br /> ***Go to Post to see Code*** <br /><br /><br /><span>-- AFTER ---</span><!--color--><br /> ***Go to Post to see Code*** <br /><br />As an aside, I noticed that the lines of interest are the only ones with tabs in that file. Go figure it was a dirty tabber who introduced this terrible bug! <img rel=";&#45;&#41;" src="https://yabbforumsoftware.com/yabbfiles/Smilies/tongue.gif" alt="Tongue" title="Tongue" /> Documentation - How can I contribute a patch? https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1615797906/2#2 YaBB Development & Mods/Documentation https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1615797906/2#2 no-email@yabbforumsoftware.com (pyragony54) Wed, 17 Mar 2021 10:53:47 GMT <span>@</span><!--color--> <b>fred</b><br /><br /><br />Bitte teile mir Fehler in der √úbersetzung hier mit.<br />Auch ich mache Fehler. Vielen Dank, New Features - Remove dead messengers from the profile https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1615797739/5#5 YaBB Development & Mods/New Features https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1615797739/5#5 no-email@yabbforumsoftware.com (fred) Mon, 15 Mar 2021 14:29:34 GMT <a href="https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1615797739/4#4">Dandello wrote</a> on Mar 15<sup>th</sup>, 2021 at 2:27pm:<br /><div id="4441484C4B2500">The templates control everything.<br /> </div><!--4441484C4B2500--><br /><br />Good to know, thank you. <img rel=";&#45;&#41;" src="https://yabbforumsoftware.com/yabbfiles/Smilies/smiley.gif" alt="Smiley" title="Smiley" /> YaBB Bugs - Problem sending e-mails YaBB 2.6.12 https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1595618297/6#6 YaBB Development & Mods/YaBB Bugs https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1595618297/6#6 no-email@yabbforumsoftware.com (pyragony54) Fri, 5 Mar 2021 18:57:29 GMT Unfortunately no effect, HTML is still displayed, but the mails are being delivered.<br /><br />I'll set up a test forum for you tomorrow, then you'll do it easier. But think about it, it's almost only German servers that refuse port 25. Gmail, Yahoo, and a few others accept port 25.   YaBB News - Getting Closer on 2.7 https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1551231877/2#2 YaBB Development & Mods/YaBB News https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1551231877/2#2 no-email@yabbforumsoftware.com (ProgMaster) Wed, 13 Jan 2021 21:56:32 GMT Great news Dandello. <img rel=";&#45;&#41;" src="https://yabbforumsoftware.com/yabbfiles/Smilies/smiley.gif" alt="Smiley" title="Smiley" /><br /><br />Many thanks. General Board - Why Perl Mongers don't play with mySQL https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1439561118/9#9 YaBB Development & Mods/General Board https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1439561118/9#9 no-email@yabbforumsoftware.com (Dandello) Sun, 10 Jan 2021 12:41:02 GMT Off-Topic replies have been moved to <a href="https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1610281888/0#0">this Topic</a>. 2.6.1 Mods - 'Last Active Threasd' Mod for YaBB 2.6.1 Beta1 https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1412082368/4#4 YaBB Development & Mods/2.6.1 Mods https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1412082368/4#4 no-email@yabbforumsoftware.com (Dandello) Thu, 13 Aug 2020 20:47:49 GMT This is a common issue:  ***Go to Post to see Code*** <br /><br />or better:  ***Go to Post to see Code***  since the 2.6.1 version of YaBB should not be using the 2.1 pointy brackets. 2.6.1 Mods - StopForumSpam https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1458677755/11#11 YaBB Development & Mods/2.6.1 Mods https://yabbforumsoftware.com/cgi-bin/yabb2/YaBB.pl?num=1458677755/11#11 no-email@yabbforumsoftware.com (pyragony54) Mon, 27 Jul 2020 18:57:00 GMT Okay!!!<br /><br />Once you have successfully installed XML::SAX, you should consider installing a module such as XML::LibXML to replace the slower pure-Perl parser bundled with SAX.<br /><br />If you are packaging <span>XML::SAX</span> in an alternative distribution format (such as RPM), your post-install script should check if ParserDetails.ini exists and if it doesn't, run this command:<br /><br />Install first <span>XML::LibXML</span> to the server with the putty.<br /><br /> ***Go to Post to see Code*** <br /><br /><b>And in the code we now have a great smiley face.<br />Why, that is known.</b><br /><br /><span>ParserDetails.ini</span> is newly created on the server.<br /><br />Copy the <span>Simple.pm</span> into the <span>Modules -> XML</span> because it cannot be installed on the server.<br /><br />It works.<br /><br /><br /><br />